CVE-2026-2741
Description
Specially crafted ZIP archives can escape the intended extraction directory during Node.js download and extraction in Vaadin 14.2.0 through 14.14.0, 15.0.0 through 23.6.6, 24.0.0 through 24.9.8, and 25.0.0 through 25.0.2. Vaadin’s build process can automatically download and extract Node.js if it is not installed locally. If an attacker can intercept or control this download via DNS hijacking, a MITM attack, a compromised mirror, or a supply chain attack, they can serve a malicious archive containing path traversal sequences that write files outside the intended extraction directory. Users of affected versions should use a globally preinstalled Node.js version compatible with their Vaadin version, or upgrade as follows: 14.2.0-14.14.0 to 14.14.1, 15.0.0-23.6.6 to 23.6.7, 24.0.0-24.9.8 to 24.9.9, and 25.0.0-25.0.2 to 25.0.3 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.
How to fix
- vaadin vaadin14.14.1, 23.6.7, 24.9.10, 25.0.4 or later
- com.vaadin:flow-project14.14.1, 23.6.7, 24.9.9, 25.0.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vaadin vaadin | 14.2.0 ≤ v < 14.14.1, 15.0.0 ≤ v < 23.6.7, 24.0.0 ≤ v < 24.9.10, 25.0.0 ≤ v < 25.0.4 | 14.14.1, 23.6.7, 24.9.10, 25.0.4 |
| com.vaadin:flow-projectMaven | 14.2.0 ≤ v < 14.14.1, 23.0.0 ≤ v < 23.6.7, 24.0.0 ≤ v < 24.9.9, 25.0.0 ≤ v < 25.0.3 | 14.14.1, 23.6.7, 24.9.9, 25.0.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.