CVE-2026-27577
Description
n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, additional exploits in the expression evaluation of n8n have been identified and patched following CVE-2025-68613. An authenticated user with permission to create or modify workflows could abuse crafted expressions in workflow parameters to trigger unintended system command execution on the host running n8n. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
How to fix
- n8n n8n1.123.22, 2.9.3, 2.10.1 or later
- n8n1.123.22, 2.9.3, 2.10.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| n8n n8n | v < 1.123.22, 2.0.0 ≤ v < 2.9.3, 2.10.0 ≤ v < 2.10.1 | 1.123.22, 2.9.3, 2.10.1 |
| n8nnpm | v < 1.123.22, 2.0.0 ≤ v < 2.9.3, 2.10.0 ≤ v < 2.10.1 | 1.123.22, 2.9.3, 2.10.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.