CVE-2026-27801

Medium

Description

Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Vaultwarden versions 1.34.3 and prior are susceptible to a 2FA bypass when performing protected actions. An attacker who gains authenticated access to a user’s account can exploit this bypass to perform protected actions such as accessing the user’s API key or deleting the user’s vault and organisations the user is an admin/owner of . This issue has been patched in version 1.35.0.

SeverityMedium
CVSS5.9
Exploit probability—
ProductDani-garcia Vaultwarden
PublishedMar 4, 2026
First seenMar 4, 2026
Weakness typeCWE-307CWE-307

How to fix

Update
  • dani-garcia vaultwarden1.35.0 or later

Affected products

ProductAffected versionsFixed in
dani-garcia vaultwardenv < 1.35.01.35.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.