CVE-2026-27820
Description
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
How to fix
- ruby-lang zlib3.0.1, 3.1.2, 3.2.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ruby-lang zlib | v < 3.0.1, 3.1.0 ≤ v < 3.1.2, 3.2.0 ≤ v < 3.2.3 | 3.0.1, 3.1.2, 3.2.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.