CVE-2026-27971

Critical

Description

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

SeverityCritical
CVSS9.8
Exploit probability—
ProductQwik
PublishedMar 3, 2026
First seenMar 3, 2026

How to fix

Update
  • qwik qwik1.19.1 or later
  • @builder.io/qwik1.19.1 or later

Affected products

ProductAffected versionsFixed in
qwik qwikv < 1.19.11.19.1
@builder.io/qwiknpmv < 1.19.11.19.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.