CVE-2026-2808
Medium
Description
HashiCorp Consul and Consul Enterprise 1.18.20 up to 1.21.10 and 1.22.4 are vulnerable to arbitrary file read when configured with Kubernetes authentication. This vulnerability, CVE-2026-2808, is fixed in Consul 1.18.21, 1.21.11 and 1.22.5.
SeverityMedium
CVSS6.8
Exploit probability—
ProductGithub.com/hashicorp/consul
PublishedMar 12, 2026
First seenMar 12, 2026
Weakness typeCWE-59Improper link resolution
How to fix
Update
- github.com/hashicorp/consul1.18.21, 1.22.5, 1.21.11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github.com/hashicorp/consulGo | v < 1.18.21, 1.22.0-rc1 ≤ v < 1.22.5, 1.19.0 ≤ v < 1.21.11, v < 1.22.5 | 1.18.21, 1.22.5, 1.21.11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.