CVE-2026-28223
Description
Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.
How to fix
- torchbox wagtail6.3.8, 7.0.6, 7.2.3 or later
- wagtail6.3.8, 7.0.6, 7.2.3, 7.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| torchbox wagtail | v < 6.3.8, 6.4 ≤ v < 7.0.6, 7.1 ≤ v < 7.2.3, 7.3 | 6.3.8, 7.0.6, 7.2.3 |
| wagtailPyPI | v < 6.3.8, 6.4rc1 ≤ v < 7.0.6, 7.1rc1 ≤ v < 7.2.3, 7.3rc1 ≤ v < 7.3.1, 6.4 ≤ v < 7.0.6, 7.1 ≤ v < 7.2.3 | 6.3.8, 7.0.6, 7.2.3, 7.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.