CVE-2026-28343
Description
CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. Starting in version 29.0.0 and prior to version 47.6.0, a cross-site scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This issue has been patched in version 47.6.0.
How to fix
- ckeditor ckeditor547.6.0 or later
- @ckeditor/ckeditor5-html-support47.6.0 or later
- ckeditor547.6.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ckeditor ckeditor5 | v < 47.6.0 | 47.6.0 |
| @ckeditor/ckeditor5-html-supportnpm | 29.0.0 ≤ v < 47.6.0 | 47.6.0 |
| ckeditor5npm | 29.0.0 ≤ v < 47.6.0 | 47.6.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.