CVE-2026-28384

Critical

Description

An improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daemon on the LXD server via API calls to the image and backup endpoints. This issue affected LXD from 4.12 through 6.6 and was fixed in the snap versions 5.0.6-e49d9f4 (channel 5.0/stable), 5.21.4-1374f39 (channel 5.21/stable), and 6.7-1f11451 (channel 6.0 stable). The channel 4.0/stable is not affected as it contains version 4.0.10.

SeverityCritical
CVSS9.9
Exploit probability—
ProductCanonical Lxd
PublishedMar 12, 2026
First seenMar 12, 2026

How to fix

Affected products

ProductAffected versionsFixed in
canonical lxd4.12 ≤ v < 5.0.6, 5.21.0 ≤ v < 5.21.4, 6.0 ≤ v < 6.75.0.6, 5.21.4, 6.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.