CVE-2026-28563
Medium
Description
Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
SeverityMedium
CVSS4.3
Exploit probability40. percentile0.5%
Product
Apache Airflow
PublishedMar 17, 2026
First seenMar 17, 2026
Weakness typeCWE-732CWE-732
How to fix
Update
- apache airflow3.1.8 or later
- apache-airflow3.1.8 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 3.0.0 ≤ v < 3.1.8 | 3.1.8 |
| apache-airflowPyPI | 3.0.0 ≤ v < 3.1.8 | 3.1.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.