CVE-2026-28780

Critical

Description

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Http Server
PublishedMay 5, 2026
First seenMay 5, 2026
Weakness typeCWE-122CWE-122

How to fix

Affected products

ProductAffected versionsFixed in
apache http_serverv < 2.4.672.4.67

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.