CVE-2026-28783
Description
Craft is a content management system (CMS). Prior to 5.9.0-beta.1 and 4.17.0-beta.1, Craft CMS implements a blocklist to prevent potentially dangerous PHP functions from being called via Twig non-Closure arrow functions. In order to be able to successfully execute this attack, you need to either have allowAdminChanges enabled on production, or a compromised admin account, or an account with access to the System Messages utility. Several PHP functions are not included in the blocklist, which could allow malicious actors with the required permissions to execute various types of payloads, including RCEs, arbitrary file reads, SSRFs, and SSTIs. This vulnerability is fixed in 5.9.0-beta.1 and 4.17.0-beta.1.
How to fix
- craftcms craft_cms4.17.0, 5.9.0 or later
- craftcms/cms5.9.0-beta.1, 4.17.0-beta.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 4.0.0 < v < 4.17.0, 5.0.0 < v < 5.9.0, 4.0.0, 5.0.0 | 4.17.0, 5.9.0 |
| craftcms/cmsPackagist | 5.0.0-RC1 ≤ v < 5.9.0-beta.1, 4.0.0-RC1 ≤ v < 4.17.0-beta.1 | 5.9.0-beta.1, 4.17.0-beta.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.