CVE-2026-29057

Medium

Description

Next.js is a React framework for building full-stack web applications. Starting in version 9.5.0 and prior to versions 15.5.13 and 16.1.7, when Next.js rewrites proxy traffic to an external backend, a crafted `DELETE`/`OPTIONS` request using `Transfer-Encoding: chunked` could trigger request boundary disagreement between the proxy and backend. This could allow request smuggling through rewritten routes. An attacker could smuggle a second request to unintended backend routes (for example, internal/admin endpoints), bypassing assumptions that only the configured rewrite destination/path is reachable. This does not impact applications hosted on providers that handle rewrites at the CDN level, such as Vercel. The vulnerability originated in an upstream library vendored by Next.js. It is fixed in Next.js 15.5.13 and 16.1.7 by updating that dependency’s behavior so `content-length: 0` is added only when both `content-length` and `transfer-encoding` are absent, and `transfer-encoding` is no longer removed in that code path. If upgrading is not immediately possible, block chunked `DELETE`/`OPTIONS` requests on rewritten routes at the edge/proxy, and/or enforce authentication/authorization on backend routes.

SeverityMedium
CVSS6.5
Exploit probability40. percentile0.5%
ProductVercel Next.js
PublishedMar 18, 2026
First seenMar 18, 2026
Weakness typeCWE-444CWE-444

How to fix

Update
  • vercel next.js15.5.13, 16.1.7 or later
  • next16.1.7, 15.5.13 or later

Affected products

ProductAffected versionsFixed in
vercel next.js9.5.0 ≤ v < 15.5.13, 16.0.0 ≤ v < 16.1.715.5.13, 16.1.7
nextnpm16.0.0-beta.0 ≤ v < 16.1.7, 9.5.0 ≤ v < 15.5.1316.1.7, 15.5.13

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.