CVE-2026-29068

High

Description

PJSIP is a free and open source multimedia communication library written in C. Prior to version 2.17, there is a stack buffer overflow vulnerability when pjmedia-codec parses an RTP payload contain more frames than the caller-provided frames can hold. This issue has been patched in version 2.17.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPjsip
PublishedMar 6, 2026
First seenMar 6, 2026
Weakness typeCWE-121CWE-121

How to fix

Update
  • pjsip pjsip2.17 or later

Affected products

ProductAffected versionsFixed in
pjsip pjsipv < 2.172.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.