CVE-2026-29145
Description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13. Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.
How to fix
- apache tomcat9.0.116, 10.1.53, 11.0.20 or later
- apache tomcat_native1.3.7, 2.0.14 or later
- org.apache.tomcat:tomcat-coyote-ffm9.0.116, 10.1.53, 11.0.20 or later
- org.apache.tomcat:tomcat9.0.116, 10.1.53, 11.0.20 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.83 ≤ v < 9.0.116, 10.1.1 ≤ v < 10.1.53, 11.0.0 ≤ v < 11.0.20, 10.1.0 | 9.0.116, 10.1.53, 11.0.20 |
| apache tomcat_native | 1.1.23 ≤ v < 1.3.7, 2.0.0 ≤ v < 2.0.14 | 1.3.7, 2.0.14 |
| org.apache.tomcat:tomcat-coyote-ffmMaven | 9.0.83 ≤ v < 9.0.116, 10.1.0-M7 ≤ v < 10.1.53, 11.0.0-M1 ≤ v < 11.0.20 | 9.0.116, 10.1.53, 11.0.20 |
| org.apache.tomcat:tomcatMaven | 9.0.83 ≤ v < 9.0.116, 10.1.0-M7 ≤ v < 10.1.53, 11.0.0-M1 ≤ v < 11.0.20 | 9.0.116, 10.1.53, 11.0.20 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.