CVE-2026-29146

High

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Tomcat
PublishedApr 9, 2026
First seenApr 9, 2026

How to fix

Affected products

ProductAffected versionsFixed in
apache tomcat7.0.100 ≤ v ≤ 7.0.109, 8.5.38 ≤ v ≤ 8.5.100, 9.0.13 ≤ v < 9.0.116, 10.0.0 ≤ v < 10.1.53, 11.0.0 ≤ v < 11.0.209.0.116, 10.1.53, 11.0.20
org.apache.tomcat:tomcat-tribesMaven9.0.13 ≤ v < 9.0.116, 10.1.50 ≤ v < 10.1.53, 11.0.0-M1 ≤ v < 11.0.20, 8.5.38 ≤ v ≤ 8.5.100, 7.0.100 ≤ v ≤ 7.0.1099.0.116, 10.1.53, 11.0.20
org.apache.tomcat:tomcatMaven9.0.13 ≤ v < 9.0.116, 10.1.50 ≤ v < 10.1.53, 11.0.0-M1 ≤ v < 11.0.20, 8.5.38 ≤ v ≤ 8.5.100, 7.0.100 ≤ v ≤ 7.0.1099.0.116, 10.1.53, 11.0.20

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.