CVE-2026-29177
Description
Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Craft Commerce Order details. Malicious JavaScript can be injected via the Shipping Method Name, Order Reference, or Site Name. When a user opens the order details slideout via a double-click on the order index page, the injected payload executes. This vulnerability is fixed in 4.10.2 and 5.5.3.
How to fix
- craftcms craft_commerce4.10.2, 5.5.3 or later
- craftcms/commerce4.10.2, 5.5.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_commerce | 4.0.0 ≤ v < 4.10.2, 5.0.0 ≤ v < 5.5.3 | 4.10.2, 5.5.3 |
| craftcms/commercePackagist | 4.0.0 ≤ v < 4.10.2, 5.0.0 ≤ v < 5.5.3 | 4.10.2, 5.5.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.