CVE-2026-30778
High
Description
The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL. This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0. Users are recommended to upgrade to version 10.4.0, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Skywalking
PublishedApr 15, 2026
First seenApr 15, 2026
Weakness typeCWE-202CWE-202
How to fix
Update
- apache skywalking10.4.0 or later
- org.apache.skywalking:server-core10.4.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache skywalking | 9.7.0 ≤ v < 10.4.0 | 10.4.0 |
| org.apache.skywalking:server-coreMaven | 9.7.0 ≤ v < 10.4.0 | 10.4.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.