CVE-2026-30848
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.8 and 9.5.0-alpha.8, the PagesRouter static file serving route is vulnerable to a path traversal attack that allows unauthenticated reading of files outside the configured pagesPath directory. The boundary check uses a string prefix comparison without enforcing a directory separator boundary. An attacker can use path traversal sequences to access files in sibling directories whose names share the same prefix as the pages directory (e.g. pages-secret starts with pages). This issue has been patched in versions 8.6.8 and 9.5.0-alpha.8.
How to fix
- parseplatform parse-server8.6.8, 9.5.0 or later
- parse-server8.6.8, 9.5.0-alpha.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.8, 9.0.0 ≤ v < 9.5.0, 9.5.0 | 8.6.8, 9.5.0 |
| parse-servernpm | v < 8.6.8, 9.0.0-alpha.1 ≤ v < 9.5.0-alpha.8 | 8.6.8, 9.5.0-alpha.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.