CVE-2026-30851
High
Description
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Caddy
PublishedMar 7, 2026
First seenMar 7, 2026
Weakness typeCWE-287Improper authenticationCWE-345CWE-345
How to fix
Update
- caddyserver caddy2.11.2 or later
- github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy2.11.2 or later
- github.com/caddyserver/caddy/v22.11.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| caddyserver caddy | 2.10.0 ≤ v < 2.11.2 | 2.11.2 |
| github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxyGo | 2.10.0 ≤ v < 2.11.2 | 2.11.2 |
| github.com/caddyserver/caddy/v2Go | 2.10.0 ≤ v < 2.11.2 | 2.11.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.