CVE-2026-30911
High
Description
Apache Airflow versions 3.1.0 through 3.1.7 missing authorization vulnerability in the Execution API's Human-in-the-Loop (HITL) endpoints that allows any authenticated task instance to read, approve, or reject HITL workflows belonging to any other task instance. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Apache Airflow
PublishedMar 17, 2026
First seenMar 17, 2026
Weakness typeCWE-862Missing authorization
How to fix
Update
- apache airflow3.1.8 or later
- apache-airflow3.1.8 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 3.1.0 ≤ v < 3.1.8 | 3.1.8 |
| apache-airflowPyPI | 3.1.0 ≤ v < 3.1.8 | 3.1.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.