CVE-2026-30947
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.3 and 8.6.16, class-level permissions (CLP) are not enforced for LiveQuery subscriptions. An unauthenticated or unauthorized client can subscribe to any LiveQuery-enabled class and receive real-time events for all objects, regardless of CLP restrictions. All Parse Server deployments that use LiveQuery with class-level permissions are affected. Data intended to be restricted by CLP is leaked to unauthorized subscribers in real time. This vulnerability is fixed in 9.5.2-alpha.3 and 8.6.16.
How to fix
- parseplatform parse-server8.6.16, 9.5.2 or later
- parse-server9.5.2-alpha.3, 8.6.16 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.16, 9.0.0 ≤ v < 9.5.2, 9.5.2 | 8.6.16, 9.5.2 |
| parse-servernpm | 9.0.0 ≤ v < 9.5.2-alpha.3, v < 8.6.16 | 9.5.2-alpha.3, 8.6.16 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.