CVE-2026-30962
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
How to fix
- parseplatform parse-server8.6.19, 9.5.2 or later
- parse-server9.5.2-alpha.6, 8.6.19 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.19, 9.0.0 ≤ v < 9.5.2, 9.5.2 | 8.6.19, 9.5.2 |
| parse-servernpm | 9.0.0 ≤ v < 9.5.2-alpha.6, v < 8.6.19 | 9.5.2-alpha.6, 8.6.19 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.