CVE-2026-30965
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.8 and 8.6.21, a vulnerability in Parse Server's query handling allows an authenticated or unauthenticated attacker to exfiltrate session tokens of other users by exploiting the redirectClassNameForKey query parameter. Exfiltrated session tokens can be used to take over user accounts. The vulnerability requires the attacker to be able to create or update an object with a new relation field, which depends on the Class-Level Permissions of at least one class. This vulnerability is fixed in 9.5.2-alpha.8 and 8.6.21.
How to fix
- parseplatform parse-server8.6.21, 9.5.2 or later
- parse-server9.5.2-alpha.8, 8.6.21 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.21, 9.0.0 ≤ v < 9.5.2, 9.5.2 | 8.6.21, 9.5.2 |
| parse-servernpm | 9.0.0-alpha.1 ≤ v < 9.5.2-alpha.8, v < 8.6.21 | 9.5.2-alpha.8, 8.6.21 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.