CVE-2026-3105
Description
SummaryThis advisory addresses a SQL injection vulnerability in the API endpoint used for retrieving contact activities. A vulnerability exists in the query construction for the Contact Activity timeline where the parameter responsible for determining the sort direction was not strictly validated against an allowlist, potentially allowing authenticated users to inject arbitrary SQL commands via the API. MitigationPlease update to 4.4.19, 5.2.10, 6.0.8, 7.0.1 or later. WorkaroundsNone. ReferencesIf you have any questions or comments about this advisory: Email us at [email protected]
How to fix
- acquia mautic4.4.19, 5.2.10, 6.0.8, 7.0.1 or later
- mautic/core5.2.10, 6.0.8, 7.0.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| acquia mautic | 2.10.0 ≤ v < 4.4.19, 5.0.0 ≤ v < 5.2.10, 6.0.0 ≤ v < 6.0.8, 7.0.0 ≤ v < 7.0.1 | 4.4.19, 5.2.10, 6.0.8, 7.0.1 |
| mautic/corePackagist | 2.10.0 ≤ v < 5.2.10, 6.0.0-alpha ≤ v < 6.0.8, 7.0.0-alpha ≤ v < 7.0.1 | 5.2.10, 6.0.8, 7.0.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.