CVE-2026-31800
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.12 and 8.6.25, the _GraphQLConfig and _Audience internal classes can be read, modified, and deleted via the generic /classes/_GraphQLConfig and /classes/_Audience REST API routes without master key authentication. This bypasses the master key enforcement that exists on the dedicated /graphql-config and /push_audiences endpoints. An attacker can read, modify and delete GraphQL configuration and push audience data. This vulnerability is fixed in 9.5.2-alpha.12 and 8.6.25.
How to fix
- parseplatform parse-server8.6.25, 9.5.2 or later
- parse-server9.5.2-alpha.12, 8.6.25 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.25, 9.0.0 ≤ v < 9.5.2, 9.5.2 | 8.6.25, 9.5.2 |
| parse-servernpm | 9.0.0-alpha.1 ≤ v < 9.5.2-alpha.12, v < 8.6.25 | 9.5.2-alpha.12, 8.6.25 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.