CVE-2026-31834
Description
Umbraco is an ASP.NET CMS. From 15.3.1 to before 16.5.1 and 17.2.2, A privilege escalation vulnerability has been identified in Umbraco CMS. Under certain conditions, authenticated backoffice users with permission to manage users, may be able to elevate their privileges due to insufficient authorization enforcement when modifying user group memberships. The affected functionality does not properly validate whether a user has sufficient privileges to assign highly privileged roles. This vulnerability is fixed in 16.5.1 and 17.2.2.
How to fix
- umbraco umbraco_cms16.5.1, 17.2.2 or later
- Umbraco.Cms16.5.1, 17.2.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| umbraco umbraco_cms | 15.3.1 ≤ v < 16.5.1, 17.0.0 ≤ v < 17.2.2 | 16.5.1, 17.2.2 |
| Umbraco.CmsNuGet | 15.3.1 ≤ v < 16.5.1, 17.0.0 ≤ v < 17.2.2 | 16.5.1, 17.2.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.