CVE-2026-31841

Medium

Description

Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductHyperterse
PublishedMar 12, 2026
First seenMar 12, 2026
Weakness typeCWE-433CWE-433

How to fix

Update
  • hyperterse hyperterse2.2.0 or later
  • hyperterse2.2.0 or later

Affected products

ProductAffected versionsFixed in
hyperterse hypertersev < 2.2.02.2.0
hypertersenpm2.0.0 ≤ v < 2.2.02.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-31841 · Hyperterse · Dark Radar