CVE-2026-31856
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs. MongoDB deployments are not affected. This vulnerability is fixed in 9.6.0-alpha.3 and 8.6.29.
How to fix
- parseplatform parse-server8.6.29, 9.6.0 or later
- parse-server9.6.0-alpha.3, 8.6.29 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.29, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.29, 9.6.0 |
| parse-servernpm | 9.0.0-alpha.1 ≤ v < 9.6.0-alpha.3, v < 8.6.29 | 9.6.0-alpha.3, 8.6.29 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.