CVE-2026-31879
Medium
Description
Frappe is a full-stack web application framework. Prior to 14.100.2, 15.101.0, and 16.10.0, due to a lack of validation and improper permission checks, users could modify other user's private workspaces. Specially crafted requests could lead to stored XSS here. This vulnerability is fixed in 14.100.2, 15.101.0, and 16.10.0.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Frappe
PublishedMar 11, 2026
First seenMar 11, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- frappe frappe14.100.2, 15.101.0, 16.10.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| frappe frappe | v < 14.100.2, 15.0.0 ≤ v < 15.101.0, 16.0.0 ≤ v < 16.10.0 | 14.100.2, 15.101.0, 16.10.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.