CVE-2026-31908
Critical
Description
Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Apisix
PublishedApr 14, 2026
First seenApr 14, 2026
Weakness typeCWE-75CWE-75
How to fix
Update
- apache apisix3.16.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apisix | 2.12.0 ≤ v < 3.16.0 | 3.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.