CVE-2026-31924
Medium
Description
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. tencent-cloud-cls log export uses plaintext HTTP This issue affects Apache APISIX: from 2.99.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Apache Apisix
PublishedApr 14, 2026
First seenApr 14, 2026
Weakness typeCWE-319CWE-319
How to fix
Update
- apache apisix3.16.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apisix | 2.99.0 ≤ v < 3.16.0 | 3.16.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.