CVE-2026-32098
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.9 and 8.6.35, an attacker can exploit LiveQuery subscriptions to infer the values of protected fields without directly receiving them. By subscribing with a WHERE clause that references a protected field (including via dot-notation or $regex), the attacker can observe whether LiveQuery events are delivered for matching objects. This creates a boolean oracle that leaks protected field values. The attack affects any class that has both protectedFields configured in Class-Level Permissions and LiveQuery enabled. This vulnerability is fixed in 9.6.0-alpha.9 and 8.6.35.
How to fix
- parseplatform parse-server8.6.35, 9.6.0 or later
- parse-server9.6.0-alpha.9, 8.6.35 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.35, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.35, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.9, v < 8.6.35 | 9.6.0-alpha.9, 8.6.35 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.