CVE-2026-32227

Critical

Description

SQL Injection vulnerability vulnerability in Apache Ranger. This issue affects . Users are recommended to upgrade to version 2.9.0, which fixes the issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Ranger
PublishedAug 10, 2026
First seenAug 10, 2026
Weakness typeCWE-89SQL injection

How to fix

Update
  • apache ranger2.9.0 or later

Affected products

ProductAffected versionsFixed in
apache rangerv < 2.9.02.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.