CVE-2026-32234
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.10 and 8.6.36, an attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using PostgreSQL. This vulnerability is fixed in 9.6.0-alpha.10 and 8.6.36.
How to fix
- parseplatform parse-server8.6.36, 9.6.0 or later
- parse-server9.6.0-alpha.10, 8.6.36 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.36, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.36, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.10, v < 8.6.36 | 9.6.0-alpha.10, 8.6.36 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.