CVE-2026-32242

High

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.11 and 8.6.37, Parse Server's built-in OAuth2 auth adapter exports a singleton instance that is reused directly across all OAuth2 provider configurations. Under concurrent authentication requests for different OAuth2 providers, one provider's token validation may execute using another provider's configuration, potentially allowing a token that should be rejected by one provider to be accepted because it is validated against a different provider's policy. Deployments that configure multiple OAuth2 providers via the oauth2: true flag are affected. This vulnerability is fixed in 9.6.0-alpha.11 and 8.6.37.

SeverityHigh
CVSS7.4
Exploit probability—
ProductParseplatform Parse-server
PublishedMar 12, 2026
First seenMar 12, 2026

How to fix

Update
  • parseplatform parse-server8.6.37, 9.6.0 or later
  • parse-server9.6.0-alpha.11, 8.6.37 or later

Affected products

ProductAffected versionsFixed in
parseplatform parse-serverv < 8.6.37, 9.0.0 ≤ v < 9.6.0, 9.6.08.6.37, 9.6.0
parse-servernpm9.0.0 ≤ v < 9.6.0-alpha.11, v < 8.6.379.6.0-alpha.11, 8.6.37

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-32242 · Parseplatform Parse-server · Dark Radar