CVE-2026-32248
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
How to fix
- parseplatform parse-server8.6.38, 9.6.0 or later
- parse-server9.6.0-alpha.12, 8.6.38 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.38, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.38, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.12, v < 8.6.38 | 9.6.0-alpha.12, 8.6.38 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.