CVE-2026-32264
Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, there is a Behavior injection RCE vulnerability in ElementIndexesController and FieldsController. Craft control panel administrator permissions and allowAdminChanges must be enabled for this to work. This issue has been patched in versions 4.17.5 and 5.9.11.
How to fix
- craftcms craft_cms4.17.5, 5.9.11 or later
- craftcms/cms4.17.5, 5.9.11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 4.0.0.1 ≤ v < 4.17.5, 5.0.1 ≤ v < 5.9.11, 4.0.0, 5.0.0 | 4.17.5, 5.9.11 |
| craftcms/cmsPackagist | 4.0.0-RC1 ≤ v < 4.17.5, 5.0.0-RC1 ≤ v < 5.9.11 | 4.17.5, 5.9.11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.