CVE-2026-32269
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.13 and 8.6.39, the OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request. Deployments using the OAuth2 adapter with appidField and appIds configured are affected. This vulnerability is fixed in 9.6.0-alpha.13 and 8.6.39.
How to fix
- parseplatform parse-server8.6.39, 9.6.0 or later
- parse-server9.6.0-alpha.13, 8.6.39 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | 8.0.2 ≤ v < 8.6.39, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.39, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.13, 8.0.2 ≤ v < 8.6.39 | 9.6.0-alpha.13, 8.6.39 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.