CVE-2026-32327
Critical
Description
A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Apr-util
PublishedAug 6, 2026
First seenAug 6, 2026
Weakness typeCWE-674CWE-674
How to fix
Update
- apache apr-util1.6.4 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apr-util | v < 1.6.4 | 1.6.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.