CVE-2026-32594
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.40 and 9.6.0-alpha.14, the GraphQL WebSocket endpoint for subscriptions does not pass requests through the Express middleware chain that enforces authentication, introspection control, and query complexity limits. An attacker can connect to the WebSocket endpoint and execute GraphQL operations without providing a valid application or API key, access the GraphQL schema via introspection even when public introspection is disabled, and send arbitrarily complex queries that bypass configured complexity limits. This vulnerability is fixed in 8.6.40 and 9.6.0-alpha.14.
How to fix
- parseplatform parse-server8.6.40, 9.6.0 or later
- parse-server9.6.0-alpha.14, 8.6.40 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 8.6.40, 9.0.0 ≤ v < 9.6.0, 9.6.0 | 8.6.40, 9.6.0 |
| parse-servernpm | 9.0.0 ≤ v < 9.6.0-alpha.14, v < 8.6.40 | 9.6.0-alpha.14, 8.6.40 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.