CVE-2026-32600
Description
xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.
How to fix
- simplesamlphp xml-security1.13.9, 2.3.1 or later
- simplesamlphp/xml-security2.3.1, 1.13.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| simplesamlphp xml-security | v < 1.13.9, 2.0.0 ≤ v < 2.3.1 | 1.13.9, 2.3.1 |
| simplesamlphp/xml-securityPackagist | 2.0.0 ≤ v < 2.3.1, v < 1.13.9 | 2.3.1, 1.13.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.