CVE-2026-32794

Medium

Description

Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice. This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.

SeverityMedium
CVSS4.8
Exploit probability—
ProductApache Airflow Providers Databricks
PublishedMar 30, 2026
First seenMar 30, 2026
Weakness typeCWE-295CWE-295

How to fix

Update
  • apache airflow_providers_databricks1.12.0 or later
  • apache-airflow1.12.0 or later

Affected products

ProductAffected versionsFixed in
apache airflow_providers_databricks1.10.0 ≤ v < 1.12.01.12.0
apache-airflowPyPI1.10.0 ≤ v < 1.12.01.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.