CVE-2026-32935
Medium
Description
phpseclib is a PHP secure communications library. Projects using versions 0.1.1 through 1.0.26, 2.0.0 through 2.0.51, and 3.0.0 through 3.0.49 are vulnerable to a to padding oracle timing attack when using AES in CBC mode. This issue has been fixed in versions 1.0.27, 2.0.52 and 3.0.50.
SeverityMedium
CVSS5.9
Exploit probability—
ProductPhpseclib
PublishedMar 20, 2026
First seenMar 20, 2026
Weakness typeCWE-208CWE-208
How to fix
Update
- phpseclib phpseclib1.0.27, 2.0.52, 3.0.50 or later
- phpseclib/phpseclib3.0.50, 2.0.52, 1.0.27 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| phpseclib phpseclib | v < 1.0.27, 2.0.0 ≤ v < 2.0.52, 3.0.0 ≤ v < 3.0.50 | 1.0.27, 2.0.52, 3.0.50 |
| phpseclib/phpseclibPackagist | 3.0.0 ≤ v < 3.0.50, 2.0.0 ≤ v < 2.0.52, 0.1.1 ≤ v < 1.0.27 | 3.0.50, 2.0.52, 1.0.27 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.