CVE-2026-32990

Medium

Description

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Tomcat
PublishedApr 9, 2026
First seenApr 9, 2026

How to fix

Update
  • apache tomcat9.0.116, 10.1.53, 11.0.20 or later
  • org.apache.tomcat:tomcat-coyote9.0.116, 10.1.53, 11.0.20 or later
  • org.apache.tomcat:tomcat9.0.116, 10.1.53, 11.0.20 or later
  • org.apache.tomcat.embed:tomcat-embed-core9.0.116, 10.1.53, 11.0.20 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.113 ≤ v < 9.0.116, 10.1.50 ≤ v < 10.1.53, 11.0.15 ≤ v < 11.0.209.0.116, 10.1.53, 11.0.20
org.apache.tomcat:tomcat-coyoteMaven9.0.113 ≤ v < 9.0.116, 10.1.50 ≤ v < 10.1.53, 11.0.15 ≤ v < 11.0.209.0.116, 10.1.53, 11.0.20
org.apache.tomcat:tomcatMaven9.0.113 ≤ v < 9.0.116, 10.1.50 ≤ v < 10.1.53, 11.0.15 ≤ v < 11.0.209.0.116, 10.1.53, 11.0.20
org.apache.tomcat.embed:tomcat-embed-coreMaven9.0.113 ≤ v < 9.0.116, 10.1.50 ≤ v < 10.1.53, 11.0.15 ≤ v < 11.0.209.0.116, 10.1.53, 11.0.20

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.