CVE-2026-33028
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui application is vulnerable to a Race Condition. Due to the complete absence of synchronization mechanisms (Mutex) and non-atomic file writes, concurrent requests lead to the severe corruption of the primary configuration file (app.ini). This vulnerability results in a persistent Denial of Service (DoS) and introduces a non-deterministic path for Remote Code Execution (RCE) through configuration cross-contamination. This issue has been patched in version 2.3.4.
How to fix
- nginxui nginx_ui2.3.4 or later
- uozi cosy1.30.1 or later
- github.com/uozi-tech/cosy1.30.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nginxui nginx_ui | v < 2.3.4 | 2.3.4 |
| uozi cosy | v < 1.30.1 | 1.30.1 |
| github.com/0xJacky/Nginx-UIGo | v ≤ 1.99, No range specified | — |
| github.com/uozi-tech/cosyGo | v < 1.30.1 | 1.30.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.