CVE-2026-33074
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, a user may be able to purchase a lower tier subscription but grant themselves the benefits that comes along with a higher tier subscription. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
How to fix
- discourse discourse2026.1.3, 2026.2.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | 2026.1.0 ≤ v < 2026.1.3, 2026.2.0 ≤ v < 2026.2.2, 2026.3.0 | 2026.1.3, 2026.2.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.