CVE-2026-33159
Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.8 and from version 5.0.0-RC1 to before version 5.9.14, guest users can access Config Sync updater index, obtain signed data, and execute state-changing Config Sync actions (regenerate-yaml, apply-yaml-changes) without authentication. This issue has been patched in versions 4.17.8 and 5.9.14.
How to fix
- craftcms craft_cms4.17.8, 5.9.14 or later
- craftcms/cms5.9.14, 4.17.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 4.0.0 < v < 4.17.8, 5.0.0 < v < 5.9.14, 4.0.0, 5.0.0 | 4.17.8, 5.9.14 |
| craftcms/cmsPackagist | 5.0.0-RC1 ≤ v < 5.9.14, 4.0.0-RC1 ≤ v < 4.17.8 | 5.9.14, 4.17.8 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.