CVE-2026-33212

Low

Description

Weblate is a web based localization tool. In versions prior to 5.17, the tasks API didn't verify user access for pending tasks. This could expose logs of in-progress operations to users who don't have access to given scope. The attacker needs to brute-force the random UUID of the task, so exploiting this is unlikely with the default API rate limits. This issue has been fixed in version 5.17.

SeverityLow
CVSS3.1
Exploit probability—
ProductWeblate
PublishedApr 15, 2026
First seenApr 15, 2026

How to fix

Update
  • weblate weblate5.17 or later
  • weblate5.17 or later

Affected products

ProductAffected versionsFixed in
weblate weblatev < 5.175.17
weblatePyPIv < 5.175.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.