CVE-2026-33214

Medium

Description

Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't enforce proper access control. This issue has been fixed in version 5.17. If users are unable to update immediately, they can work around this issue by blocking access to /api/memory/ in the HTTP server, which removes access to this feature.

SeverityMedium
CVSS4.3
Exploit probability—
ProductWeblate
PublishedApr 15, 2026
First seenApr 15, 2026

How to fix

Update
  • weblate weblate5.17 or later
  • weblate5.17 or later

Affected products

ProductAffected versionsFixed in
weblate weblatev < 5.175.17
weblatePyPIv < 5.175.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.